Back to overview
Degraded

Network Issues

Apr 29 at 09:25pm BST

Resolved
Apr 29 at 11:05pm BST

All services have returned back to operational!

Updated
Apr 29 at 10:12pm BST

We believe we have found the issue and have fixed it.

Please allow us 5-10 minutes to gather information to see if this has resolved the outage.

Created
Apr 29 at 09:25pm BST

We're aware of an issue causing the server to lag, we a looking into this and working on a fix.