Back to overview
Degraded
Server Bugs
Apr 26 at 10:12pm BST
Resolved
Apr 27 at 12:48pm BST
We have resolved this issue now!
Affected services
Updated
Apr 26 at 10:47pm BST
We're still working on this issue.
The texture loss and bugs should be minimized now however, we are monitoring it.
Affected services
Created
Apr 26 at 10:12pm BST
We are aware of current issues in-city which are affecting textures and other elements of the city.
Our Developers are working to fix this.
Affected services